Dodawanie wartości spełniających określone kryterium - SUMA.JEŻELI()

Marta Mrozowska   Informacja Zarządcza 17/2019 Tylko on-line
Gdyby chcieć dodać wartości, które spełniają jakieś konkretne kryterium, warto zastosować formułę SUMA.JEŻELI().

Konstrukcja tej formuły zbudowana jest w następujący sposób: w pierwszej kolejności wskazujemy zakres (czyli obszar zawierający kryteria, które będą brane pod uwagę, przy wykonaniu działania), następnie wpisujemy kryterium (jeśli jest to wartość tekstowa, to musi być wpisana w cudzysłowie) lub wskazujemy odwołanie do komórki, w której to kryterium występuje, na koniec podajemy zakres sumy (obszar, w którym znajdują się wartości liczbowe, które mają być dodawane). Przykład użycia tej formuły pokazano na rysunku 1.

Przykładowo, jeśli mając do dyspozycji cały Rachunek Zysków i Strat, chcielibyśmy pokazać wartości w ujęciu mocno uproszczonym, np. w podziale na przychody i koszty, to można np.: dodać wszystkie przychody występujące w Rachunku wpisując w komórkę C27 formułę =SUMA.JEŻELI(A5:A24;A27;C5:C24), gdzie

  1. A5:A24 - zakres kryteriów (czyli w tym przypadku podział danych na przychody i koszty);
  2. A27 – komórka, w której znajduje się wybrane kryterium, dla którego chcemy zsumować wartości (w tym przypadku słowo „przychody”;
  3. C5:C24 – obszar, w którym znajdują się wartości liczbowe, które chcemy dodawać.

Warto zwrócić uwagę, że zakresy dla punktów 1 i 3 mają identyczne numery wierszy – jest to niezbędne, aby formuła prawidłowo wykonała obliczenia.

Dostęp możliwy dla zalogowanych użytkowników serwisu. Jeśli posiadasz aktywną prenumeratę przejdź do LOGOWANIA. Jeśli nie jesteś jeszcze naszym Czytelnikiem wybierz najkorzystniejszy WARIANT PRENUMERATY.

Zaloguj Zamów prenumeratę
Drukuj

Zobacz również

Archiwum

Polecamy