Czasami zdarza się, że w Excelu formuła zwraca błąd lub dane nie są poprawne. Jak sobie poradzić w takiej sytuacji? Przede wszystkim trzeba poznać rodzaje błędów, na jakie można trafić.

Obsługa błędów w Excelu

Błędy zwracane przez formuły

Zaczniemy od tabeli zawierającej błędy, które mogą zwracać formuły (Tabela 1).

Komunikaty błędów zwracane przez formuły są mało przyjazne dla człowieka, dlatego jeśli wiadomo, z jakiego powodu się pojawiły, można zastąpić je przyjaznym komunikatem. Na przykład funkcja WYSZUKAJ.PIONOWO zwraca błąd #N/D!, kiedy nie uda jej się znaleźć produktu na liście (Rysunek 1):

=WYSZUKAJ.PIONOWO(B2;$F$4:$G$10;2;0)

My chcemy ten komunikat błędu zamienić na bardziej zrozumiałą / tekstową informację. Możemy w tym celu użyć funkcji JEŻELI.BŁĄD, ewentualnie JEŻELI.ND (Excel 2013), które w sytuacji napotkania błędu zwracają inną wartość. Funkcja JEŻELI.ND reaguje tylko na błąd #N/D!. W takiej sytuacji poprawiona formuła może wyglądać następująco:

=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B2;$F$4:$G$10;2;0);”Brak produktu”)

Pozostałe 82% artykułu dostępne jest dla zalogowanych użytkowników serwisu.

Jeśli posiadasz aktywną prenumeratę przejdź do LOGOWANIA. Jeśli nie jesteś jeszcze naszym Czytelnikiem wybierz najkorzystniejszy WARIANT PRENUMERATY.

Zaloguj Zamów prenumeratę Kup dostęp do artykułu

Możesz zobaczyć ten artykuł, jak i wiele innych w naszym portalu Controlling 24. Wystarczy, że klikniesz tutaj.

Ulubione Drukuj

Zobacz również

Tylko on-line nr 27/2021

Wykresy wodospadowe w praktyce

Wykresy są często nieodłącznym narzędziem wykorzystywanym przy różnego rodzaju raportach. Ich zadaniem jest zarówno przekazać pewne merytoryczne dane, jak również przyciągnąć uwagę odbiorcy. Jako że większość z nas jest wzrokowcami, to dobrze stworzony wykres pozwoli zapamiętać najważniejsze dane czy różne zależności.

Czytaj więcej

Pętle w Excelu

Pętle w Excelu

Język VBA (ang. Visual Basic for Applications) jest językiem programowania obsługującym aplikacje pakietu Microsoft Office, do których należy m.in. Excel. Celem pracy w VBA jest automatyzacja zadań wykonywanych na dokumentach za pomocą makropoleceń. Jednym z podstawowych narzędzi dostępnych w VBA są pętle.

Czytaj więcej

Przejdź do

Partnerzy

Reklama